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 Important Information

Warranty
The media on which you receive National Instruments software are warranted not to fail to execute programming 
instructions, due to defects in materials and workmanship, for a period of 90 days from date of shipment, as evidenced 
by receipts or other documentation. National Instruments will, at its option, repair or replace software media that do not 
execute programming instructions if National Instruments receives notice of such defects during the warranty period. 
National Instruments does not warrant that the operation of the software shall be uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside 
of the package before any equipment will be accepted for warranty work. National Instruments will pay the shipping costs 
of returning to the owner parts which are covered by warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully 
reviewed for technical accuracy. In the event that technical or typographical errors exist, National Instruments reserves 
the right to make changes to subsequent editions of this document without prior notice to holders of this edition. The 
reader should consult National Instruments if errors are suspected. In no event shall National Instruments be liable for 
any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL  INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS 
ANY WARRANTY OF MERCHANTABILITY  OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’ S RIGHT TO RECOVER DAMAGES CAUSED 
BY FAULT OR NEGLIGENCE ON THE PART OF NATIONAL  INSTRUMENTS SHALL BE LIMITED  TO THE AMOUNT THERETOFORE PAID BY THE 
CUSTOMER. NATIONAL  INSTRUMENTS WILL  NOT BE LIABLE  FOR DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, 
OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF. This limitation of the liability of 
National Instruments will apply regardless of the form of action, whether in contract or tort, including negligence. 
Any action against National Instruments must be brought within one year after the cause of action accrues. National 
Instruments shall not be liable for any delay in performance due to causes beyond its reasonable control. The warranty 
provided herein does not cover damages, defects, malfunctions, or service failures caused by owner’s failure to follow 
the National Instruments installation, operation, or maintenance instructions; owner’s modification of the product; 
owner’s abuse, misuse, or negligent acts; and power failure or surges, fire, flood, accident, actions of third parties, 
or other events outside reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, 
including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without 
the prior written consent of National Instruments Corporation.

Trademarks
ComponentWorks™, HiQ™, HiQ-Script™, and natinst.com™ are trademarks of National Instruments Corporation.

Product and company names mentioned herein are trademarks or trade names of their respective companies.

WARNING REGARDING MEDICAL AND CLINICAL USE OF NATIONAL INSTRUMENTS PRODUCTS
National Instruments products are not designed with components and testing for a level of reliability suitable for use in 
or in connection with surgical implants or as critical components in any life support systems whose failure to perform 
can reasonably be expected to cause significant injury to a human. Applications of National Instruments products 
involving medical or clinical treatment can create a potential for death or bodily injury caused by product failure, or by 
errors on the part of the user or application designer. Because each end-user system is customized and differs from 
National Instruments testing platforms and because a user or application designer may use National Instruments products 
in combination with other products in a manner not evaluated or contemplated by National Instruments, the user or 
application designer is ultimately responsible for verifying and validating the suitability of National Instruments products 
whenever National Instruments products are incorporated in a system or application, including, without limitation, 
the appropriate design, process and safety level of such system or application.



Conventions

The following conventions are used in this manual: 

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence Help»HiQ Reader Help Topics directs you 
to pull down the Help menu and select the HiQ Reader Help Topics item. 

This icon denotes a note, which alerts you to important information.

bold Bold text denotes the names of menus and dialog box buttons or options.

italic Italic text denotes emphasis, a cross reference, or an introduction to a key 
concept.

monospace Text in this font denotes text or characters that you should literally enter 
from the keyboard, sections of code, programming examples, and syntax 
examples. This font is also used for the proper names of disk drives, paths, 
directories, parameters, functions, variables, filenames and extensions, and 
for statements and comments taken from programs.
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1
Getting Started with HiQ Reader

This chapter introduces the HiQ Reader application, lists system 
requirements and installation instructions, and explains how to get started 
with HiQ Reader.

About HiQ Reader
The HiQ Reader enables you to interact with HiQ Professional Notebooks. 
You can open HiQ Professional Notebooks, run scripts, view the analysis 
and visualization results, and print and save the Notebooks. Refer to 
Chapter 2, Getting Results with HiQ Reader Notebooks, for information 
about Notebooks and extracting the data you need from it.

Note HiQ Reader can open only Notebooks saved in HiQ Professional version.

The HiQ Reader is available for free from either your HiQ Professional CD 
or from the National Instruments Web site at www.natinst.com/hiq .

System Requirements
HiQ Reader requires the following minimum system configuration:

• Windows 95 or Windows 98/NT 4.0

• 486 CPU with coprocessor

• 8 MB RAM with Windows 95, 16 MB RAM with Windows 98/NT

• 256-color, 800 by 600 VGA display

• 20 MB free disk space

The following specifications are the recommended system configuration 
for HiQ Reader:

• Windows NT 4.0

• Pentium 90 or higher

• 16 MB RAM with Windows 95, 32 MB RAM with Windows 98/NT

• Accelerated True Color, 1024 by 768 display

• 20 MB free disk space
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Installing HiQ Reader
HiQ Reader is part of the HiQ Professional edition. Use one of the 
following procedures to install the HiQ Reader application:

• If you purchased HiQ Professional:

1. Insert the HiQ Professional CD in the CD-ROM drive of your 
computer.

2. Follow the Setup instructions you see on your screen. Be sure to 
select the HiQ Reader option.

• If you do not have HiQ Professional:

1. Visit the National Instruments Web site at www.natinst.com and 
follow the links to HiQ.

2. Click Download HiQ Reader and save the file to your computer.

3. Double click on the .EXE  file that you downloaded.

4. Follow the Setup instructions you see on your screen.

By default, the HiQ Reader installation program creates a new folder, 
C:\Program Files\National Instruments\HiQReader , that 
contains the following items:

• Program  folder—HiQReader.exe , HiQ Reader help files, and 
related files

• Problem Solvers  folder—Example Problem Solver Notebooks

• Readme.txt  file—Late-breaking information about HiQ, known 
limitations, and corrections

• Manuals  folder—PDF version of this manual
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Getting Started with HiQ Reader

Launching and Exiting HiQ Reader
Use one of the following methods to launch HiQ Reader:

• Use the Start Button.

1. Click on the Windows Start button and select the 
Programs menu.

2. Select the National Instruments HiQ  submenu.

3. Click on HiQ Reader.

• Use Windows Explorer.

1. Locate the HiQ Reader executable, HiQReader.exe , 
in Windows Explorer.

2. Double click HiQReader.exe .

Use the following step to exit HiQ Reader:

1. Save the Notebook if you have made any changes to any objects.

2. Select File»Exit.

Opening and Closing HiQ Reader Notebooks
Use the following steps to open and close HiQ Reader Notebooks:

1. Launch HiQ Reader.

2. Select File»Open.

3. Navigate to the file you want to open, select the file, and press Open.

4. Interact with the Notebook. You can run scripts and print and save the 
Notebook. You cannot create new objects, delete objects, or modify the 
format of the Notebook. Refer to Chapter 2, Getting Results with HiQ 
Reader Notebooks, for more information about Notebooks and 
interacting with them.

Note HiQ Reader can open all Notebooks saved as HiQ Reader Notebooks (.HQR) and 
HiQ Notebooks saved in HiQ Professional. HiQ Professional Notebooks are saved 
with the same extension as those created in the base version of HiQ (.HIQ ). HiQ 
Reader displays an error message if you try to open an Notebook that was not 
saved in HiQ Professional.
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Figure 1-1 shows the Filtering Problem Solver Notebook, which you 
can find in the \Problem Solvers  folder. This figure labels 
important parts of the HiQ Reader and some of the elements on the 
Notebook page. For more information about getting results with a 
Problem Solver, see Notebook Example: Expression Evaluator in 
Chapter 2, Getting Results with HiQ Reader Notebooks.

Figure 1-1.  HiQ Reader Environment

5. To close the Notebook, select File»Close.

Status Bar Script StatusHiQ Graph ObjectsHiQ-Script Object
     in Run View

ComponentWorks ActiveX ControlsSection TabsNotebook Explorer
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Getting Help

HiQ Reader Online Help
HiQ Reader offers tooltips, context-sensitive help, and online help that you 
can access in the following ways.

• You can access the HiQ Reader online help by selecting HiQ Reader 
Help Topics from the Help menu. There you find information not 
available in this manual, such as complete function reference and 
answers to How Do I...? questions.

• Tooltips appear when you move the mouse cursor over a button in any 
toolbar. The text of the tooltip indicates the function of the button. 

• A help topic appears in the status bar at the bottom of a HiQ Notebook 
as you move the mouse pointer over the menu items.

• You can click on the Help button, ?, in other areas of the HiQ user 
interface, such as dialog boxes, to access context-sensitive help for the 
next item on which you click.

Note Use the <F1> key to access context-sensitive help for a selected item or for an area 
where the cursor is located. For example, when your cursor is located in a script 
within the name of a HiQ built-in function, help for that function appears when 
you press <F1>.

Current Notebook
Notebook developers can create and distribute help for the Notebooks they 
create. Help files can have any of the formats in the following table:

File Extension File Type Description

.hlp , .cnt WinHelp Windows standard help file that 
looks and behaves similar to the 
HiQ Reader online help

.chm , .chh HTML Help Microsoft Compiled HTML Help

.htm , .html Web page HTML page that opens in your 
default Web browser

.doc Word 
document

Microsoft Word document

.txt Text file Plain text file that opens in your 
default text editor
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If you receive any files with these extensions with a HiQ Reader Notebook, 
place all files in the same directory. When the Notebook is open in the HiQ 
Reader, you can access the help by selecting Help»Help for Current 
Notebook.
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2
Getting Results with HiQ Reader 
Notebooks

This chapter introduces the features of the HiQ Notebook interface and 
shows you how to interact with HiQ Reader Notebooks in HiQ Reader.

About HiQ Reader Notebooks
HiQ uses a notebook as the basic interface metaphor. The HiQ Notebook 
has features that you normally associate with a real engineering or 
scientific Notebook, such as pages, sections, and tabs.

The following sections describe the elements you might encounter as you 
interact with Notebooks. To see example Notebooks, browse through the 
Notebooks installed in the Problem Solvers  folder. Refer to Notebook 
Example: Expression Evaluator later in this chapter for information about 
Problem Solvers and interacting with them.

Notebook Objects
Notebook developers can arrange information in a free-form manner on 
Notebook pages. Each piece of information that the developer places on a 
Notebook page is known as an object. As with a real notebook, many types 
of objects can be placed on a page, including text, numerics, and graphs.

You can interact with some objects on a Notebook page. For example, 
you can edit text in text objects, and you can rotate, zoom, and pan 
three-dimensional graphs. The Notebook developer also might include 
controls that allow you to modify the properties of an object. For example, 
they might include an option that allows you to select the plot style for a 
graph.
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Scripts
The HiQ Notebook includes an object known as the HiQ-Script object. 
HiQ-Script is the built-in programming language that accesses the HiQ 
library of analysis and visualization functions.

In most Notebooks, you will see scripts in Run View. Run View is a special 
view of the script object that hides the script that performs the analysis or 
visualizes the data. Figure 2-1 shows the Expression Evaluator Notebook, 
which contains two scripts in Run View: Evaluate and Clear. When you 
press the run button (arrow) for the Evaluate script, the expression is plotted 
on the graph. When you press the run button for Clear, the plots are 
removed from the graph. If you receive a Notebook with a script that is not 
in Run View, right click on the script object and select Run to execute 
the script.

Figure 2-1.  Expression Evaluator Problem Solving Scripts
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Working with Multiple Windows
HiQ products use the standard Multiple Document Interface (MDI) that 
Microsoft Office products like Word and Excel use. A main window exists 
within which multiple HiQ Notebooks may reside. From the Windows 
menu, you can maximize, overlay, or tile the Notebook windows you open.

Interacting with a Notebook
A well designed Notebook should be self-documenting, describing how 
to interact with the Notebook. Interaction might be as simple as entering 
a start time and a stop time for simulation of a system of differential 
equations. Or a Notebook might instruct you to select a data file to import 
in order to calculate and graph the amount of rainfall in a particular area. 

Most Notebooks include scripts that you can run to solve the type of 
mathematical or visualization problem the Notebook was designed to 
handle.

Notebook Example: Expression Evaluator
This section presents the Expression Evaluator Problem Solver to 
demonstrate how you can interact with HiQ Reader Notebooks. Problem 
Solvers are HiQ Notebooks designed to interact with users to analyze or 
solve a wide range of problems belonging to a certain class. In a Problem 
Solver, you can enter a different set of data or analysis problems without 
having to modify script.

Perform the following steps to learn more about the Expression Evaluator 
Notebook.

Opening the Notebook
1. Launch HiQ Reader from the Windows Start menu 

(Start»Programs»National Instruments HiQ»HiQ Reader).

2. Select File»Open.

3. Open the Problem Solvers  folder within the HiQReader  folder.

4. Select Expression Evaluator.HiQ  and click Open. The 
Expression Evaluator Notebook opens.
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Entering Data and Running Scripts
This Notebook can evaluate any mathematical expression and display its 
behavior graphically.

1. Click the Evaluate button to evaluate the expression. The Notebook 
evaluates the default expression over 128 points, starting at 1 and 
ending at 4. The graph displays the result.

2. Enter the mathematical expression sin(x)*cos(x)  into the text 
object labeled F(x) =.

3. Click the Evaluate button to evaluate the expression. Figure 2-2 shows 
the Expression Evaluator Problem Solver after it has evaluated two 
expressions.

Figure 2-2.  Evaluating Expressions with the Expression Evaluator Notebook

4. Evaluate your own expression, varying the domain interval and 
number of points plotted to see how this Problem Solver behaves. 
You can press the Clear button to remove all plots.
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The expression you entered is fed into the numerical algorithm in the 
script. The plot that appears when you run the script is a graphical 
representation of the mathematical expression that you entered.

Note You must use valid operators and valid HiQ built-in functions. In this example, 
your expression must be in terms of x. Refer to the HiQ Reader online help by 
selecting Help»HiQ Reader Help Topics for complete descriptions of operators 
and built-in functions.

More Reader Notebooks: Problem Solvers
HiQ Reader comes with several other problem solvers that address various 
areas in science and engineering. Check the \Problem Solvers  directory 
for Notebooks that solve the following types of problems:

• Filtering

• Windowing

• Data Fitting

• Optimization

• Root Finding

• Differential Equations

• Integration

• Nonlinear Systems
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A
Technical Support Resources

National Instruments offers technical support through electronic, fax, and 
telephone systems. The electronic services include our Web site, an FTP 
site, and a fax-on-demand system. If you have a hardware or software 
problem, please first try the electronic support systems. If the information 
available on these systems does not answer your questions, contact one of 
our technical support centers, which are staffed by applications engineers, 
for support by telephone and fax. To comment on the documentation 
supplied with our products, send e-mail to techpubs@natinst.com .

Web Site
The InstrumentationWeb address is www.natinst.com . 

From this Web site you can connect to our Web sites around the 
world (www.natinst.com/niglobal/ ) and access technical support 
(www.natinst.com/support/ ).

FTP Site
To access our FTP site, log in to our Internet host, ftp.natinst.com , 
asanonymous  and use your e-mail address, such as 
yourname@anywhere.com , as your password. The support files and 
documents are located in the \support  directories.

Fax-on-Demand Support
Fax-on-Demand is a 24-hour information retrieval system containing a 
library of documents in English on a wide range of technical information. 
You can access Fax-on-Demand from a touch-tone telephone at 
512 418 1111.

E-Mail Support
You can submit technical support questions to the applications engineering 
team through e-mail at support@natinst.com . Remember to include 
your name, address, and phone number so we can contact you with 
solutions and suggestions. 
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Telephone and Fax Support
National Instruments has branch offices all over the world. Use the 
following list to find the technical support number for your country. If there 
is no National Instruments office in your country, contact the source from 
which you purchased your software to obtain support.

Country Telephone Fax

Australia 03 9879 5166 03 9879 6277

Austria 0662 45 79 90 0 0662 45 79 90 19

Belgium 02 757 00 20 02 757 03 11

Brazil 011 284 5011 011 288 8528

Canada (Ontario) 905 785 0085 905 785 0086

Canada (Québec) 514 694 8521 514 694 4399

Denmark 45 76 26 00 45 76 26 02

Finland 09 725 725 11 09 725 725 55

France 0 1 48 14 24 24 0 1 48 14 24 14

Germany 089 741 31 30 089 714 60 35

Hong Kong 2645 3186 2686 8505

India 91805275406 91805275410

Israel 03 6120092 03 6120095

Italy 02 413091 02 4139215

Japan 03 5472 2970 03 5472 2977

Korea 02 596 7456 02 596 7455

Mexico (D.F.) 5 280 7625 5 520 3282

Mexico (Monterrey) 8 357 7695 8 365 8543

Netherlands 0348 433466 0348 430673

Norway 32 84 84 00 32 84 86 00

Singapore 2265886 2265887

Spain (Madrid) 91 640 0085 91 640 0533

Spain (Barcelona) 93 582 0251 93 582 4370

Sweden 08 587 895 00 08 730 43 70

Switzerland 056 200 51 51 056 200 51 55

Taiwan 02 2377 1200 02 2737 4644

United Kingdom 01635 523545 01635 523154

United States 512 795 8248 512 794 5678
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Glossary

Prefix Meanings Value

p- pico- 10–12

n- nano- 10–9

µ- micro- 10– 6

m- milli- 10–3

k- kilo- 103

M- mega- 106

G- giga- 109

t- tera- 1012

A

ActiveX 
(Microsoft ActiveX)

A programming system and user interface that lets you work with 
interactive objects. Formerly called OLE.

ActiveX control A standard software tool that adds additional functionality to any 
compatible ActiveX container.

B

built-in function One of many programming utilities in HiQ-Script that perform analysis, 
graphical, or utility operations.

C

compiled script A HiQ object containing HiQ-Script language that has been converted to 
code that a computer uses to execute the program.

ComponentWorks A collection of 32-bit ActiveX controls designed for building virtual 
instrumentation systems.
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E

error message An information box that appears when HiQ cannot complete an action due 
to an internal error, compile error, run-time error, or user error.

Explorer See HiQ Explorer.

expression A mathematical operator and its operands.

H

HiQ Explorer An interactive window displaying the objects, sections, and pages of an 
open Notebook.

HIQ extension Extension for a HiQ base or professional version Notebook. Only 
Notebooks saved in HiQ Professional can be opened in HiQ Reader.

HiQ Professional Professional version of HiQ, which includes the following elements: 
HiQ, HiQ Signal Processing Toolkit, ComponentWorks User Interface 
ActiveX controls, ComponentWorks DataSocket ActiveX control, 
ComponentWorks 3D Graph ActiveX control, Serial Interface ActiveX 
control, and HiQ Reader.

HiQ Reader HiQ product that enables HiQ Professional users to distribute their 
Notebooks. HiQ Reader users can view and interact with Notebooks but 
cannot modify the format of the Notebook, create new objects, or create 
new notebooks.

HiQ-Script The intuitive HiQ programming language for mathematics.

HQR extension Extension for a HiQ Reader Notebook.

N

Notebook The workspace in HiQ that stores, organizes, and displays all the 
components of an analysis and visualization problem.
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O

object An entity in a HiQ Notebook that contains data of a specific type, for 
example, numeric, graphic, text, or HiQ-Script. Objects work together in a 
Notebook to generate and display solutions to analysis and visualization 
problems. Objects are always stored in a Notebook, but are not always 
visible on a Notebook page. See object view.

object view A HiQ object that is visible on a Notebook page.

operand An object (or objects) modified by an operator.

operator Code in HiQ-Script that is specific to basic mathematical operations and 
structure of HiQ-Script language. Often represented as a symbol, for 
example, "/ " represents division.

P

pop-up menu A context-sensitive menu that you can access by right clicking with your 
mouse on an object or on the Notebook.

Problem Solver A HiQ Notebook containing objects, including HiQ-Script, that allows you 
to interactively perform analysis of data and display results for a broad class 
of problems. For example, the Expression Evaluator Problem Solver can 
display the results of any expression.

R

Reader See HiQ Reader.

Run View View of the script object that displays 2 buttons—one to run the script and 
the other to stop the script—and hides the script source.

S

script A block of code that performs a certain task. See HiQ-Script and compiled 
script.

script object A HiQ object type containing HiQ-Script and from which you compile and 
execute your program.
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section tabs An organizing tool in a HiQ Notebook that lets you label and quickly access 
different parts of your Notebook.

Standard toolbar Site on the user interface of HiQ that contains basic utility tools, for 
example, Save, Open, Cut, Paste, and, Print . Depending on your 
preference, the toolbar can appear on any edge of the interface, or as a 
floating window.

status bar A region, usually the bottom of a window, containing information about 
HiQ and any selected object.

T

toolbar Site on an application interface that contains various buttons and other 
controls. Depending on your preference, a toolbar can appear on any edge 
of the interface, or a floating window.

tooltip A small, descriptive pop-up window that appears when you position the 
mouse cursor over a toolbar icon.
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